Taiwan Hadoop Forum

台灣 Hadoop 技術討論區
現在的時間是 2022-06-29, 03:21

所有顯示的時間為 UTC + 8 小時




發表新文章 回覆主題  [ 3 篇文章 ] 
發表人 內容
 文章主題 : 啟動datanode
文章發表於 : 2014-04-17, 17:13 
離線

註冊時間: 2014-03-25, 15:53
文章: 3
小弟用了兩台作一個叢集
1:master(namenode)
2:cluser(datanode)

在master端輸入/usr/local/hadoop/sbin/start-dfs.sh
出現:Starting namenodes on [master]
master: starting namenode, logging to /usr/local/hadoop-0.23.9/logs/hadoop-hadoop-namenode-master.out
master: starting datanode, logging to /usr/local/hadoop-0.23.9/logs/hadoop-hadoop-datanode-master.out
cluser: starting datanode, logging to /usr/local/hadoop-0.23.9/logs/hadoop-hadoop-datanode-cluser.out
Starting secondary namenodes [0.0.0.0]
0.0.0.0: starting secondarynamenode, logging to /usr/local/hadoop-0.23.9/logs/hadoop-hadoop-secondarynamenode-master.out

當執行到cluser: starting datanode, logging to /usr/local/hadoop-0.23.9/logs/hadoop-hadoop-datanode-cluser.out
的時候,在cluser端有jps跟datanode在執行,但是往下執行時datanose就消失了
而且在master也只有1305 Jps
648 NameNode
1262 SecondaryNameNode

想請問為什麼無法正確開啟datanode呢?


回頂端
 個人資料 E-mail  
 
 文章主題 : Re: 啟動datanode
文章發表於 : 2014-04-20, 18:16 
離線

註冊時間: 2009-11-09, 19:52
文章: 2897
請先觀察 /usr/local/hadoop-0.23.9/logs/hadoop-hadoop-datanode-master.log 的內容
很可能遇到 namespace 不相符的問題。

- Jazz


回頂端
 個人資料 E-mail  
 
 文章主題 : Re: 啟動datanode
文章發表於 : 2014-04-21, 19:28 
離線

註冊時間: 2014-03-25, 15:53
文章: 3
謝謝jazz大大 :D
果然是namespcae出了問題
小弟去爬討論namespce的文章並且依照指令:
rm -rf /tmp/hadoop/hadoop-root/dfs/data
/opt/hadoop/bin/hadoop-daemon.sh start datanode
就可以正常運作了


回頂端
 個人資料 E-mail  
 
顯示文章 :  排序  
發表新文章 回覆主題  [ 3 篇文章 ] 

所有顯示的時間為 UTC + 8 小時


誰在線上

正在瀏覽這個版面的使用者:沒有註冊會員 和 1 位訪客


不能 在這個版面發表主題
不能 在這個版面回覆主題
不能 在這個版面編輯您的文章
不能 在這個版面刪除您的文章
不能 在這個版面上傳附加檔案

搜尋:
前往 :  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
正體中文語系由 竹貓星球 維護製作