Taiwan Hadoop Forum

台灣 Hadoop 技術討論區
現在的時間是 2017-03-25, 09:48

所有顯示的時間為 UTC + 8 小時




發表新文章 回覆主題  [ 4 篇文章 ] 
發表人 內容
 文章主題 : HBASE 啟動問題
文章發表於 : 2015-12-10, 14:14 
離線

註冊時間: 2015-11-10, 00:43
文章: 16
安裝環境:

VB 5.0.4
Ubuntu 15.04
hadoop 2.5.0
hbase 1.0.0
java-7-oracle


設置如下:

一台Master 三台Slave

分別在兩台主機下的VB運行

確定可以互相PING的到對方

HBASE的hbase-site.xml配置如下


代碼:
<configuration>

  <property>
        <name>hbase.master</name>
        <value>Master:60000</value>
  </property>
  <property>
    <name>hbase.rootdir</name>
    <value>hdfs://Master:9000/hbase</value>
    <description>The directory shared by region servers.</description>
  </property>
  <property>
    <name>hbase.tmp.dir</name>
    <value>/usr/local/hadoop/hbase-0.98.5-hadoop2/tmp</value>
    <description>Temporary directory on the local filesystem.</description>
  </property>
  <property>
    <name>hbase.cluster.distributed</name>
    <value>true</value>
    <description>The mode the cluster will be in. Possible values are
      false: standalone and pseudo-distributed setups with managed Zookeeper
      true: fully-distributed with unmanaged Zookeeper Quorum (see hbase-env.sh)</description>
  </property>
  <property>
      <name>hbase.zookeeper.property.clientPort</name>
      <value>2181</value>
      <description>Property from ZooKeeper's config zoo.cfg.</description>
  </property>
  <property>
      <name>hbase.zookeeper.quorum</name>
      <value>ggg@Slave1,ggg@Slave2,gg@Slave3</value>
      <description>Comma separated list of servers in the ZooKeeper Quorum.</description>
  </property>
  <property>
      <name>hbase.zookeeper.property.dataDir</name>
      <value>/usr/local/hadoop/hbase-0.98.5-hadoop2/zookeeper</value>
  </property>
  <property>
            <name>hbase.zookeeper.property.maxClientCnxns</name>
            <value>1000</value>
  </property>
  <property>
            <name>hbase.zookeeper.dns.nameserver</name>
            <value>default</value>
            <description>The host name or IP address of the name server (DNS) which a ZooKeeper server should use to determine the host name used by the master for communication and display purposes. </description>
  </property>
  <property>
            <name>hbase.zookeeper.dns.interface</name>
            <value>default</value>
            <description>The name of the Network Interface from which a ZooKeeper server should report its IP address. </description>
  </property>


</configuration>





slave節點上的logs

代碼:
WARN  [regionserver60020-SendThread(Master:2222)] zookeeper.ClientCnxn: Session 0x0 for server null, unexpected error, closing socket connection and attempting reconnect
java.net.ConnectException: 連線被拒絕


Master上的logs

代碼:
WARN  [main] util.NativeCodeLoader: Unable to load native-hadoop library for your platform... using builtin-java classes where applicable
WARN  [main] zookeeper.ZKConfig: java.net.UnknownHostException: ggg@Slave1: 未知的名稱或服務
WARN  [main] zookeeper.ZKConfig: java.net.UnknownHostException: ggg@Slave2: 未知的名稱或服務
WARN  [main] zookeeper.ZKConfig: java.net.UnknownHostException: gg@Slave3: 未知的名稱或服務



啟動完logs出現以上的bug

Master啟動完JPS後沒有出現Hmaster

Slave沒有出現Hquorumpeer, Hregionserver


不知道什麼原因 也查了很多網路上的資料

煩請各位大大指點迷津 QQ


回頂端
 個人資料 E-mail  
 
 文章主題 : Re: HBASE 啟動問題
文章發表於 : 2015-12-10, 21:28 
離線

註冊時間: 2009-11-09, 19:52
文章: 2889
GGG 寫:
HBASE的hbase-site.xml配置如下
代碼:
  <property>
      <name>hbase.zookeeper.quorum</name>
      <value>ggg@Slave1,ggg@Slave2,gg@Slave3</value>
      <description>Comma separated list of servers in the ZooKeeper Quorum.</description>
  </property>



把 hbase-site.xml 上面那段設定改成
代碼:
  <property>
      <name>hbase.zookeeper.quorum</name>
      <value>Slave1,Slave2,Slave3</value>
      <description>Comma separated list of servers in the ZooKeeper Quorum.</description>
  </property>

試試看

- Jazz


回頂端
 個人資料 E-mail  
 
 文章主題 : Re: HBASE 啟動問題
文章發表於 : 2015-12-11, 17:20 
離線

註冊時間: 2015-11-10, 00:43
文章: 16
jazz 寫:
GGG 寫:
HBASE的hbase-site.xml配置如下
代碼:
  <property>
      <name>hbase.zookeeper.quorum</name>
      <value>ggg@Slave1,ggg@Slave2,gg@Slave3</value>
      <description>Comma separated list of servers in the ZooKeeper Quorum.</description>
  </property>



把 hbase-site.xml 上面那段設定改成
代碼:
  <property>
      <name>hbase.zookeeper.quorum</name>
      <value>Slave1,Slave2,Slave3</value>
      <description>Comma separated list of servers in the ZooKeeper Quorum.</description>
  </property>

試試看

- Jazz



請問Jazz大大,user@Master 的用戶名與 ggg@Slave1 的用戶名user與ggg不同會有影響嗎??
因為若我設
代碼:
<value>Slave1,Slave2,Slave3</value>

Master會去抓user@Slave1,而非ggg@Slave1。

煩請Jazz大大提點迷津。


回頂端
 個人資料 E-mail  
 
 文章主題 : Re: HBASE 啟動問題
文章發表於 : 2015-12-11, 22:55 
離線

註冊時間: 2009-11-09, 19:52
文章: 2889
GGG 寫:
請問Jazz大大,user@Master 的用戶名與 ggg@Slave1 的用戶名user與ggg不同會有影響嗎??
因為若我設
代碼:
<value>Slave1,Slave2,Slave3</value>

Master會去抓user@Slave1,而非ggg@Slave1。
煩請Jazz大大提點迷津。


1. 這裡的設定是 ZooKeeper 的主機名稱,不是 SSH 連線。
2. 過去有蠻多人都遇到不同帳號啟動造成的問題,建議用相同帳號。

- Jazz


回頂端
 個人資料 E-mail  
 
顯示文章 :  排序  
發表新文章 回覆主題  [ 4 篇文章 ] 

所有顯示的時間為 UTC + 8 小時


誰在線上

正在瀏覽這個版面的使用者:沒有註冊會員 和 1 位訪客


不能 在這個版面發表主題
不能 在這個版面回覆主題
不能 在這個版面編輯您的文章
不能 在這個版面刪除您的文章
不能 在這個版面上傳附加檔案

搜尋:
前往 :  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
正體中文語系由 竹貓星球 維護製作