Taiwan Hadoop Forum

台灣 Hadoop 技術討論區
現在的時間是 2018-10-18, 03:08

所有顯示的時間為 UTC + 8 小時




發表新文章 回覆主題  [ 9 篇文章 ] 
發表人 內容
 文章主題 : 嗨有沒有人會使用OpenNEbula+XEN的sunstone創設VM??
文章發表於 : 2012-03-10, 19:42 
離線

註冊時間: 2011-11-24, 20:51
文章: 26
Dear all:
有人可以跟我分享一下經驗的嗎?
我不太懂設定檔如何設定...
我之前上網有找到一個範例
但那是運行在Ubuntu + ONE + KVM的
我需要CentOS + ONE + XEN的VM Template設定方式
Template有一個欄位是要填Boot/OS options
Boot method有Bootloader和Kernel我選用Kernel
帶是接下來的Kernel和Initrd我卻不知道該填什麼資訊...
雖然他有解釋kernel為path to the OS kernel to boot the image
而Initrd為path to the initrd image
但是我還是不知道我該填的內容為什麼...

先說我製作img檔的方式好了
我用virsh-install透過網路安裝好一個img
參考網頁如http://www.howtoforge.com/virtualization-with-xen-on-centos-6.2-x86_64-paravirtualization-and-hardware-virtualization-p2
安裝好OS之後我會得到一個img,這樣子的做法是正確的嗎?
我雖然有一個img檔,但卻沒有initrd檔....

請問板上的高手可以指導我一下嗎?

國網中心的教學太舊...也沒有講到sunstone...
請大家幫幫忙了 >"<
謝謝大家


回頂端
 個人資料 E-mail  
 
 文章主題 : Re: 嗨有沒有人會使用OpenNEbula+XEN的sunstone創設VM??
文章發表於 : 2012-03-11, 00:05 
離線

註冊時間: 2009-11-09, 19:52
文章: 2897
CINMEX 寫:
國網中心的教學太舊...也沒有講到sunstone...


無奈啊~這方面的人才很缺,國網中心培養好的人(先前教學文件的作者)被挖角去業界啦~
那誰來寫教學呢 :(

最近有用 SunStone 的應該是這篇吧
http://trac.nchc.org.tw/grid/wiki/adher ... M_DRBL_ONE

- Jazz


回頂端
 個人資料 E-mail  
 
 文章主題 : Re: 嗨有沒有人會使用OpenNEbula+XEN的sunstone創設VM??
文章發表於 : 2012-03-11, 19:36 
離線

註冊時間: 2011-11-24, 20:51
文章: 26
jazz 寫:
CINMEX 寫:
國網中心的教學太舊...也沒有講到sunstone...


無奈啊~這方面的人才很缺,國網中心培養好的人(先前教學文件的作者)被挖角去業界啦~
那誰來寫教學呢 :(

最近有用 SunStone 的應該是這篇吧
http://trac.nchc.org.tw/grid/wiki/adher ... M_DRBL_ONE

- Jazz


謝謝Jazz回覆,不過的確國內好少人討論,都得去國外論壇,只是我遇到的問題是用OpenNEbula開啟VM的時候出現一個ERROR
Error: Device 768 (tap) could not be connected.
不知道如何解決
我是用CentOS6 +XEN +OpenNEbula出現這個ERROR
而網路上有人是使用Debian + OpenNEbula出現這個ERROR
但他說是Debian的一個bug如以下連結...
http://comments.gmane.org/gmane.comp.di ... .user/4420

唉...找不到解決辦法,這禮拜老師回國我就挫咧但了 >"<


回頂端
 個人資料 E-mail  
 
 文章主題 : Re: 嗨有沒有人會使用OpenNEbula+XEN的sunstone創設VM??
文章發表於 : 2012-03-12, 09:51 
離線

註冊時間: 2009-11-09, 19:52
文章: 2897
CINMEX 寫:
Error: Device 768 (tap) could not be connected.
不知道如何解決


有裝 bridge-utils ?
您有建立 tap 網路裝置?
下 ifconfig 看一下?

- Jazz


回頂端
 個人資料 E-mail  
 
 文章主題 : Re: 嗨有沒有人會使用OpenNEbula+XEN的sunstone創設VM??
文章發表於 : 2012-03-12, 13:32 
離線

註冊時間: 2012-03-12, 13:24
文章: 3
題外話
是指rock被挖角了嗎@@

難怪opennebula 的技術手冊一直都停在1.4版

一年多前,還去國網讓他們上過相關課程



jazz大,能幫忙解決這問題嗎

請教一下


OS 為xen4.1
Opennebula版本為3.0

one已可以順利啟動,實體機器的資源也可以加入

但在onevm create xxx.one的時候,都會失敗

查看log,也去google過,但都沒人有同樣問題

log如下,紅色地方為error的地方

Mon Mar 12 12:52:45 2012 [DiM][I]: New VM state is ACTIVE.
Mon Mar 12 12:52:46 2012 [LCM][I]: New VM state is PROLOG.
Mon Mar 12 12:52:46 2012 [VM][I]: Virtual Machine has no context
Mon Mar 12 12:56:24 2012 [TM][D]: tm_clone.sh: T7500-3:/home/domains/ST6/disk.img T7500-3:/home/one/var//30/images/disk.0
Mon Mar 12 12:56:24 2012 [TM][D]: tm_clone.sh: DST: /home/one/var//30/images/disk.0
Mon Mar 12 12:56:24 2012 [TM][I]: tm_clone.sh: Creating directory /home/one/var//30/images
Mon Mar 12 12:56:24 2012 [TM][I]: tm_clone.sh: Executed "ssh T7500-3 mkdir -p /home/one/var//30/images".
Mon Mar 12 12:56:24 2012 [TM][I]: tm_clone.sh: Cloning T7500-3:/home/domains/ST6/disk.img
Mon Mar 12 12:56:24 2012 [TM][I]: tm_clone.sh: Executed "scp T7500-3:/home/domains/ST6/disk.img T7500-3:/home/one/var//30/images/disk.0".
Mon Mar 12 12:56:24 2012 [TM][I]: tm_clone.sh: Executed "ssh T7500-3 chmod a+rw /home/one/var//30/images/disk.0".
Mon Mar 12 12:56:24 2012 [TM][I]: ExitCode: 0
Mon Mar 12 12:56:31 2012 [LCM][I]: New VM state is BOOT
Mon Mar 12 12:56:31 2012 [VMM][I]: Generating deployment file: /home/one/var/30/deployment.0
Mon Mar 12 12:56:32 2012 [VMM][I]: Command execution fail: 'if [ -x "/var/tmp/one/vmm/xen/deploy" ]; then /var/tmp/one/vmm/xen/deploy /home/one/var//30/images/deployment.0 T7500-3 30 T7500-3; else exit 42; fi'
Mon Mar 12 12:56:32 2012 [VMM][I]: Error: ('create', '-aaio:/home/one/var//30/images/disk.0') failed (32512 )

Mon Mar 12 12:56:32 2012 [VMM][E]: Unable
Mon Mar 12 12:56:32 2012 [VMM][I]: ExitCode: 1
Mon Mar 12 12:56:32 2012 [VMM][E]: Error deploying virtual machine: Unable
Mon Mar 12 12:56:33 2012 [DiM][I]: New VM state is FAILED
Mon Mar 12 12:58:30 2012 [DiM][I]: New VM state is DONE.
Mon Mar 12 12:58:33 2012 [TM][W]: Ignored: LOG I 30 tm_delete.sh: Deleting /home/one/var//30/images

Mon Mar 12 12:58:33 2012 [TM][W]: Ignored: LOG I 30 tm_delete.sh: Executed "ssh T7500-3 rm -rf /home/one/var//30/images".

Mon Mar 12 12:58:33 2012 [TM][W]: Ignored: LOG I 30 ExitCode: 0

Mon Mar 12 12:58:33 2012 [TM][W]: Ignored: TRANSFER SUCCESS 30 -


回頂端
 個人資料 E-mail  
 
 文章主題 : Re: 嗨有沒有人會使用OpenNEbula+XEN的sunstone創設VM??
文章發表於 : 2012-03-12, 22:58 
離線

註冊時間: 2009-11-09, 19:52
文章: 2897
194g0042 寫:
Mon Mar 12 12:56:31 2012 [LCM][I]: New VM state is BOOT
Mon Mar 12 12:56:31 2012 [VMM][I]: Generating deployment file: /home/one/var/30/deployment.0
Mon Mar 12 12:56:32 2012 [VMM][I]: Command execution fail: 'if [ -x "/var/tmp/one/vmm/xen/deploy" ]; then /var/tmp/one/vmm/xen/deploy /home/one/var//30/images/deployment.0 T7500-3 30 T7500-3; else exit 42; fi'
Mon Mar 12 12:56:32 2012 [VMM][I]: Error: ('create', '-aaio:/home/one/var//30/images/disk.0') failed (32512 )

Mon Mar 12 12:56:32 2012 [VMM][E]: Unable
Mon Mar 12 12:56:32 2012 [VMM][I]: ExitCode: 1
Mon Mar 12 12:56:32 2012 [VMM][E]: Error deploying virtual machine: Unable
Mon Mar 12 12:56:33 2012 [DiM][I]: New VM state is FAILED
Mon Mar 12 12:58:30 2012 [DiM][I]: New VM state is DONE.
Mon Mar 12 12:58:33 2012 [TM][W]: Ignored: LOG I 30 tm_delete.sh: Deleting /home/one/var//30/images
Mon Mar 12 12:58:33 2012 [TM][W]: Ignored: LOG I 30 tm_delete.sh: Executed "ssh T7500-3 rm -rf /home/one/var//30/images".


一定要 Xen 嘛?最近我們都改玩 KVM 了耶~try http://ezilla.info

從錯誤訊息看起來,有點奇怪的地方是產生的檔案在 /home/one/var/30/deployment.0
但是程式碼卻是要執行 /home/one/var//30/images/deployment.0
您不妨去查一下路徑的設定(紅字部份怪怪的,有兩個 // 然後多一個 images)。

- Jazz


回頂端
 個人資料 E-mail  
 
 文章主題 : Re: 嗨有沒有人會使用OpenNEbula+XEN的sunstone創設VM??
文章發表於 : 2012-03-14, 05:25 
離線

註冊時間: 2011-11-24, 20:51
文章: 26
jazz 寫:
194g0042 寫:
Mon Mar 12 12:56:31 2012 [LCM][I]: New VM state is BOOT
Mon Mar 12 12:56:31 2012 [VMM][I]: Generating deployment file: /home/one/var/30/deployment.0
Mon Mar 12 12:56:32 2012 [VMM][I]: Command execution fail: 'if [ -x "/var/tmp/one/vmm/xen/deploy" ]; then /var/tmp/one/vmm/xen/deploy /home/one/var//30/images/deployment.0 T7500-3 30 T7500-3; else exit 42; fi'
Mon Mar 12 12:56:32 2012 [VMM][I]: Error: ('create', '-aaio:/home/one/var//30/images/disk.0') failed (32512 )

Mon Mar 12 12:56:32 2012 [VMM][E]: Unable
Mon Mar 12 12:56:32 2012 [VMM][I]: ExitCode: 1
Mon Mar 12 12:56:32 2012 [VMM][E]: Error deploying virtual machine: Unable
Mon Mar 12 12:56:33 2012 [DiM][I]: New VM state is FAILED
Mon Mar 12 12:58:30 2012 [DiM][I]: New VM state is DONE.
Mon Mar 12 12:58:33 2012 [TM][W]: Ignored: LOG I 30 tm_delete.sh: Deleting /home/one/var//30/images
Mon Mar 12 12:58:33 2012 [TM][W]: Ignored: LOG I 30 tm_delete.sh: Executed "ssh T7500-3 rm -rf /home/one/var//30/images".


一定要 Xen 嘛?最近我們都改玩 KVM 了耶~try http://ezilla.info

從錯誤訊息看起來,有點奇怪的地方是產生的檔案在 /home/one/var/30/deployment.0
但是程式碼卻是要執行 /home/one/var//30/images/deployment.0
您不妨去查一下路徑的設定(紅字部份怪怪的,有兩個 // 然後多一個 images)。

- Jazz

抱歉~這麼晚才回覆您訊息。
如同您說的,路徑是那樣子沒錯....
我在/home/one/var/30/底下找得到deployment.0檔案
但是/home/one/var//30/images/底下卻找不到disk.0檔案....
不知道是什麼原因會導致disk.0傳不過去(是sever傳不過去client嗎?還是什麼怪異的原因導致client沒有該檔案?這是我的問題>"<)
Anyway,感謝Jazz的幫忙!!!


回頂端
 個人資料 E-mail  
 
 文章主題 : Re: 嗨有沒有人會使用OpenNEbula+XEN的sunstone創設VM??
文章發表於 : 2012-03-15, 14:19 
離線

註冊時間: 2009-11-09, 19:52
文章: 2897
CINMEX 寫:
我在/home/one/var/30/底下找得到deployment.0檔案
但是/home/one/var//30/images/底下卻找不到disk.0檔案....
不知道是什麼原因會導致disk.0傳不過去(是sever傳不過去client嗎?還是什麼怪異的原因導致client沒有該檔案?這是我的問題>"<)
Anyway,感謝Jazz的幫忙!!!


/home/one/var/30/底下找得到deployment.0檔案 -> 這是在 server ???
/home/one/var//30/images/底下卻找不到disk.0檔案.... -> 這是在 client ???

首先要注意一下設定檔,結尾可能多打了一個 / 還有就是 client 的設定檔裡頭是否多了 images ??
傳不過去的原因有很多 (1) 權限 (2) scp 金鑰交換沒作
先前我們都會用 NFS 共享 /home
不知道您的環境是???

- Jazz


回頂端
 個人資料 E-mail  
 
 文章主題 : Re: 嗨有沒有人會使用OpenNEbula+XEN的sunstone創設VM??
文章發表於 : 2012-03-16, 05:38 
離線

註冊時間: 2011-11-24, 20:51
文章: 26
jazz 寫:
CINMEX 寫:
我在/home/one/var/30/底下找得到deployment.0檔案
但是/home/one/var//30/images/底下卻找不到disk.0檔案....
不知道是什麼原因會導致disk.0傳不過去(是sever傳不過去client嗎?還是什麼怪異的原因導致client沒有該檔案?這是我的問題>"<)
Anyway,感謝Jazz的幫忙!!!


/home/one/var/30/底下找得到deployment.0檔案 -> 這是在 server ???
/home/one/var//30/images/底下卻找不到disk.0檔案.... -> 這是在 client ???

首先要注意一下設定檔,結尾可能多打了一個 / 還有就是 client 的設定檔裡頭是否多了 images ??
傳不過去的原因有很多 (1) 權限 (2) scp 金鑰交換沒作
先前我們都會用 NFS 共享 /home
不知道您的環境是???

- Jazz

哈我找到原因了
NFS沒mount好 = =
不好意思還麻煩Jazz大大跟我討論 >"<

不過接下來還是有問題
我先處理看看,不懂再上來請教
謝謝你!!


回頂端
 個人資料 E-mail  
 
顯示文章 :  排序  
發表新文章 回覆主題  [ 9 篇文章 ] 

所有顯示的時間為 UTC + 8 小時


誰在線上

正在瀏覽這個版面的使用者:沒有註冊會員 和 1 位訪客


不能 在這個版面發表主題
不能 在這個版面回覆主題
不能 在這個版面編輯您的文章
不能 在這個版面刪除您的文章
不能 在這個版面上傳附加檔案

搜尋:
前往 :  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
正體中文語系由 竹貓星球 維護製作