Taiwan Hadoop Forum

台灣 Hadoop 技術討論區
現在的時間是 2017-12-15, 10:45

所有顯示的時間為 UTC + 8 小時




發表新文章 回覆主題  [ 6 篇文章 ] 
發表人 內容
 文章主題 : Datanode not starting, Hadoop 2.2 on Redhat 6.5
文章發表於 : 2015-10-21, 17:00 
離線

註冊時間: 2015-10-21, 15:30
文章: 5
Namenode works fine, anyone has same experience before ?


回頂端
 個人資料 E-mail  
 
 文章主題 : Re: Datanode not starting, Hadoop 2.2 on Redhat 6.5
文章發表於 : 2015-10-23, 17:48 
離線

註冊時間: 2009-11-09, 19:52
文章: 2895
bureaucrat 寫:
Namenode works fine, anyone has same experience before ?


Not sure. We install CDH4.7 (with Hadoop 2.0) and CDH 5.3.1 ( with Hadoop 2.5.0 ) on CentOS 6.5 and RHEL 6.
Everything is fine.

Is there any error message ?

- Jazz


回頂端
 個人資料 E-mail  
 
 文章主題 : Re: Datanode not starting, Hadoop 2.2 on Redhat 6.5
文章發表於 : 2015-10-26, 10:52 
離線

註冊時間: 2015-10-21, 15:30
文章: 5
jazz 寫:
bureaucrat 寫:
Namenode works fine, anyone has same experience before ?


Not sure. We install CDH4.7 (with Hadoop 2.0) and CDH 5.3.1 ( with Hadoop 2.5.0 ) on CentOS 6.5 and RHEL 6.
Everything is fine.

Is there any error message ?

- Jazz



I installed Hadoop 2.6 on Ubuntun with Oracle JDK 1.8, it works fine.

No special error message, just when I run start-dfs.sh, when It goes to start DataNode, the script doesnt even ask me for SSH password ( it asked SSH password for NameNode and SecondNamenade)

bash-4.1$ jps
6705 SecondaryNameNode
6298 NameNode
7487 Jps


回頂端
 個人資料 E-mail  
 
 文章主題 : Re: Datanode not starting, Hadoop 2.2 on Redhat 6.5
文章發表於 : 2015-10-26, 11:05 
離線

註冊時間: 2015-10-21, 15:30
文章: 5
Also I tried Hadoop 2.7 with Oracle JDK 1.8 on on Redhat 6.5 today, same issue, maybe its related to the OS ?


回頂端
 個人資料 E-mail  
 
 文章主題 : Re: Datanode not starting, Hadoop 2.2 on Redhat 6.5
文章發表於 : 2015-10-26, 11:20 
離線

註冊時間: 2015-10-21, 15:30
文章: 5
Got this error always, while people told me we can ignore it, its due to 32bit hadoop on 64bit OS

15/10/25 23:18:36 WARN util.NativeCodeLoader: Unable to load native-hadoop library for your platform... using builtin-java classes where applicable


回頂端
 個人資料 E-mail  
 
 文章主題 : Re: Datanode not starting, Hadoop 2.2 on Redhat 6.5
文章發表於 : 2015-10-27, 09:42 
離線

註冊時間: 2015-10-21, 15:30
文章: 5
bureaucrat 寫:
Also I tried Hadoop 2.7 with Oracle JDK 1.8 on on Redhat 6.5 today, same issue, maybe its related to the OS ?



it turns out that port 50010 is taken by other application, that's why datanode wont start


回頂端
 個人資料 E-mail  
 
顯示文章 :  排序  
發表新文章 回覆主題  [ 6 篇文章 ] 

所有顯示的時間為 UTC + 8 小時


誰在線上

正在瀏覽這個版面的使用者:沒有註冊會員 和 2 位訪客


不能 在這個版面發表主題
不能 在這個版面回覆主題
不能 在這個版面編輯您的文章
不能 在這個版面刪除您的文章
不能 在這個版面上傳附加檔案

搜尋:
前往 :  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
正體中文語系由 竹貓星球 維護製作